通达信谷式量指标公式

返回列表
热搜课程: 益盟高级课 量学 黑马王子 淘股吧教程 老马点金 月风先生教程 缠论 唐能通股票教程 伍朝辉 爱股轩股票教程 Python量化交易 狂龙十八段 财富讲坛股市108将 游资混江龙 缠中说禅 长投学堂
通达信公式 关注:3992
公式说明

M1:=5;

M2:=10;

M3:=20;

M4:=60;

TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,TOTALFZNUM,1)))));

MTIME:=MOD(FROMOPEN,TOTAL);

CTIME:=IF(MTIME<0.5,TOTAL,MTIME);

VVOL:IF((CURRBARSCOUNT=1 AND DYNAINFO(8)>1),VOL*TOTAL/CTIME,DRAWNULL),NODRAW;

STICKLINE((CURRBARSCOUNT=1 AND DYNAINFO(8)>1),VVOL,0,-1,-1),COLOR00C0C0;

VOLUME:VOL,VOLSTICK;

MAVOL5:MA(VOLUME,M1)COLORWHITE;

MAVOL10:MA(VOLUME,M2)COLORYELLOW;

MAVOL20:MA(VOLUME,M3)COLORFF00FF;

MAVOL60:MA(VOLUME,M4)COLORGREEN;

STICKLINE(VOL>1.8*REF(VOL,1),0,VOL,2,0),COLORYELLOW;

红太阳:=IF(LOW>REF(HIGH,1) AND COUNT(OPEN<CLOSE,1),1,0);

STICKLINE(红太阳=1,V,0,0.5,0),COLORRED;

所属行业:DRAWTEXT_FIX(ISLASTBAR ,0.01,0,0,HYBLOCK),COLORYELLOW;

所属概念:DRAWTEXT_FIX(ISLASTBAR,0.15,0,0,GNBLOCK),COLORYELLOW;

DRAWICON(CROSS(MAVOL5,MAVOL10),MAVOL10,1); {K上穿D做记号};

DRAWICON(CROSS(MAVOL10,MAVOL5),MAVOL5,2); {D下穿K做记号};

T:=DYNAINFO(8)>0;

VO:=VOL=LLV(VOL,8) AND T;

地量柱:T AND VO,COLORBLUE;

STICKLINE(地量柱,0,V,1,0),COLORBLUE;

DRAWTEXT(CURRBARSCOUNT=5+1,V*1.05,'5');

DRAWTEXT(CURRBARSCOUNT=10+1,V*1.05,'10');

DRAWTEXT(CURRBARSCOUNT=20+1,V*1.05,'20');

DRAWTEXT(CURRBARSCOUNT=60+1,V*1.05,'60');

DRAWTEXT(CURRBARSCOUNT=120+2,V*1.05,'120');

DRAWTEXT(CURRBARSCOUNT=240+1,V*1.05,'240');

点击下载通达信公式调试用软件>>
赞赏本站
联系客服:
客服
返回课程列表